ADP unavailable

Incident Report for Company Alerts

Resolved

All, ADP services appear to have completely stabilized, though no notice has been given by ADP. Please reach out to IT and HR if you continue to experience issues logging into ADP
Posted Apr 24, 2023 - 13:58 PDT

Monitoring

Hello all, ADP issues appear to be mitigated at this time. Some users may still experience issues when logging in while fixes propagate, but ADP services appear to be restored.
Posted Apr 24, 2023 - 12:48 PDT

Update

Hello all, a brief update to let you know that ADP is still indicating an issue on their end, with no ETA to resolution. Any further updates will be provided as they become available.
Posted Apr 24, 2023 - 11:47 PDT

Investigating

Hello all, many people are reporting ADP as unavailable, or that it continually tries to load. ADP has indicated that they are aware of the issue and are working towards a resolution. Any updates to this situation will be provided as they become available.
Posted Apr 24, 2023 - 08:28 PDT
This incident affected: ADP.