Multiple issues with Microsoft Teams

Incident Report for Company Alerts

Resolved

This incident has been resolved.
Posted Jan 29, 2024 - 16:49 PST

Monitoring

All, Microsoft has finally reported that they are seeing wide improvements to Teams across the board and are monitoring for other problems. Please let us know if you continue to run into issues.
Posted Jan 29, 2024 - 09:29 PST

Update

All, Microsoft has reported that they have implemented several fixes and are seeing improvements to the user experience globally. They are continuing to implement the remediation as well as identifying new potential fixes to apply. We will continue to provide updates as they become available.
Posted Jan 26, 2024 - 15:11 PST

Identified

Microsoft has attempted a fix to the Teams issues on their end, but has reported that issues are still present. They are attempting another fix at this time.

We will provide more updates as they become available.
Posted Jan 26, 2024 - 13:02 PST

Investigating

All, Microsoft has alerted us that there is an ongoing incident with Microsoft Teams that they are investigating. Currently known issues include:
- Users logging in or unlocking their devices after some time may see missing messages
- Users may fail to load messages in channels and chats
- Users are unable to view or download their media (images, videos, audio, call recordings, code snippets)
- Some messages may experience delays being sent

We will provide further updates as Microsoft provides them to us.
Posted Jan 26, 2024 - 09:45 PST
This incident affected: Microsoft 365 (Microsoft 365 | Teams).