Microsoft reports the issue has been fully resolved. Please reach out to the IT department if you are experiencing any issues with Microsoft 365 services.
Posted Apr 20, 2023 - 14:28 PDT
Monitoring
Microsoft has reported that a fix has been implemented and they are seeing that many users are now able to access Microsoft 365 applications normally. They are continuing to monitor the issue to ensure it is fully resolved. Resolution details will be provided when received, if applicable.
Posted Apr 20, 2023 - 13:12 PDT
Investigating
Microsoft is currently experiencing issues with Microsoft 365 apps and services. Some users may not be able to view or access Microsoft 365 apps such as Teams, Outlook, Word, Excel, SharePoint, etc. If you are unable to access one of these apps, a workaround is to access the applications directly through the URL. Some examples of these URLs include: Outlook - outlook.office.com Microsoft Teams - teams.microsoft.com Word Online - microsoft365.com/launch/word Excel Online - microsoft365.com/launch/excel
Updates will be provided as they are received from Microsoft.
Posted Apr 20, 2023 - 10:01 PDT
This incident affected: Microsoft 365 (Microsoft 365 | Email, Microsoft 365 | Teams).