Salesforce for Outlook plugin issues

Incident Report for Company Alerts

Resolved

The large amount of people experiencing this problem has dwindled. Salesforce support has notified us that this is an issue they are actively investigating, noted here: https://issues.salesforce.com/issue/a028c00000y527l/users-encounter-this-page-has-an-er%5b%E2%80%A6%5dt-promiserejection-object-object-when-using-outlook-add-in

Further updates to this problem will be sent directly to the team via email.
Posted May 28, 2024 - 14:34 PDT

Investigating

A significant amount of people are reporting issues with email logging and other features in the Salesforce Outlook plugin. As a workaround, please open things up in Salesforce through your browser and attach needed items that way. We are investigating the issue and will provide updates as we are able.
Posted May 23, 2024 - 09:16 PDT
This incident affected: Salesforce (Salesforce Production).