Issues with multiple Microsoft 365 services

Incident Report for Company Alerts

Resolved

All: Microsoft is reporting that they have identified the problematic update that caused these issues and has remediated accordingly. After an extended monitoring period, the issues appear to be resolved. Please reach out to IT if you are still experiencing any issues with the Microsoft 365 suite.
Posted Jun 05, 2023 - 12:44 PDT

Investigating

Hi all, Microsoft is reporting that some people are experiencing issues with Microsoft 365 services, but specifically with using Outlook on the web (OWA) or attempting to perform several operations in Teams. However, other services such as SharePoint and OneDrive may also be affected to a currently unknown extent. We will provide updates as we have them - please reach out to IT if you have any questions.
Posted Jun 05, 2023 - 08:53 PDT
This incident affected: Microsoft 365 (Microsoft 365 | Email, Microsoft 365 | OneDrive, Microsoft 365 | Teams).