Microsoft 365 products inaccessible

Incident Report for Company Alerts

Resolved

Microsoft is reporting this issue as resolved. Please reach out to IT if you are experiencing any problems with the Microsoft products.
Posted Nov 26, 2024 - 10:49 PST

Monitoring

Microsoft has reported that their fix has been implemented and they have seen significant improvement on the reported issues. They are continuing to monitor the issue to ensure it has been fully resolved.
Posted Nov 25, 2024 - 13:42 PST

Identified

Microsoft has identified an issue that is preventing users from opening Outlook or performing certain functions in Teams and other Microsoft 365 apps. They have implemented a mitigation strategy and are working towards a resolution. Further updates will be provided when they are available.
Posted Nov 25, 2024 - 10:36 PST
This incident affected: Microsoft 365 (Microsoft 365 | Email, Microsoft 365 | Teams).